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A. Put a tick (√) the correct option. 

  

 1.  You can create a duplicate block by : 

 (a) Right Clicking                            (√)      

 (b) Double Clicking 

 (c) Left Clicking                                   

 (d) All of these                                           

  

2. Which of these is not a step in logical thinking ? 

 (a) Task 

 (b) Identify                  

 (c) Solve 

 (d) Problem                                       (√)           

  

3. What are the different operators used in Scratch ? 

 (a) Addition 

 (b) Subtraction                      

 (c) Division 

 (d) All of these                                  (√) 

  

4. Which block is used to generate numbers ? 

 (a) Operators                                      (√) 

 (b) Sensing 

 (c) Control                                    

 (d) Motion      

  

5. Logical thinking is done in ___ steps. 

 (a) 2 

 (b) 3                    

 (c) 4                                                       (√) 

 (d) 5                              

B. Fill in the blanks. 

 

 Four       String    One         Round    Sensing 

  

1. Operator blocks are Round in shape. 

2. When a word is saved in a variable,it is called a String. 

3. Variables can hold One value at a time. 

4. Sensing blocks are blue colour coded. 

5. Logical thinking is done in four steps. 

 

  



C. Write ‘T’ for true and ‘F’ for false statements. 

  

1. You can perform mathematical operations in scratch.                                          ( T ) 

2. Operator blocks are red in colour.                                                                         ( F ) 

3. With Scratch, you can count the number of letters in a word.                              ( T ) 

4. A variable can’t hold numbers as value.                                                               ( F ) 

5. You can’t compare values using scratch.                                                              ( F ) 

  

D. Match the following. 

 1. Pick random 1 to 10 a. Motion block 

2. Set variable to 0 b. Looks block 

3. Move 10 steps c. Operator block 

4. Say Hello for 2 secs d. Sensing block 

5. Ask ‘whats your name’ and wait e. Variable block 

 

Answer:-  1-d,  2-e,  3-a,  4-b,  5-c.  

 

 

E. Answer the following questions. 
  

1. What is a variable and why is it used in Scratch ?  

 

Ans: A variable is a place holder for some values. In Scratch, data blocks are used as variables 

and are represented with blocks shaped like elongated circles, uniquely labelled by a user. 

They can hold numbers or strings but one at a time.  
  

2. What are the main steps used in logical thinking? 

  

Ans: The main steps in logical thinking are: 

1. Task 

2. Identify 

3. Solve 

4. Solution 
  

3. What are the sensing blocks and what are they used for ? 

  

Ans: Sensing blocks are light blue colour coded blocks and are used to sense the input while 

executing the script. 
  

4. What is ask and wait block used for and which palette does it belong to? 
  

Ans: The ask and wait block makes an input box for you to input text and submit it and then the 

desired input is stored in the Answer Block. Answer block  automatically when a new input 

is given in the input box by you. 

It belongs to Sensing block Palette. 
  

5. Why do we use conditions in programming? 

  

Ans: Conditions is applied when you want to put a check on any problem. 

  



F. Application based questions: 

  

   1 Arun is creating a project for school and wants to create a new variable in Scratch. 

Help him to do so by mentioning the process of creating a variable in Scratch. 

Ans: To be done Practically. 

2 Create a dialogue between Arun and Raju using sensing block palette. 

Ans: To be done Practically. 
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A. Put a tick (√) the correct option. 

  

 1.  The internet was originally a project of which agency ? 

 (a) ARPANET                             (√)      

 (b) NSF 

 (c) NSA                                   

 (d) None of these                                           

  

2. Which one of the following is not a search engine ? 

 (a) Bing 

 (b) Yahoo                  

 (c) Google 

 (d) Vista                                        (√)           

  

3. WWW stands for : 

 (a) World Wide Wider 

 (b) World Wide Web                     (√) 

 (c) World Wide Word 

 (d) World Wide Wrestling                 

  

4. Which of these is not required to connect to Internet ? 

 (a) Computer           

 (b) Modem 

 (c) Mouse                                     (√) 

 (d) ISP       

  

5. What can you attach to an e-mail ? 

 (a) Photos 

 (b) Video Clips                     

 (c) Audio Clips               

 (d) All of these                             (√) 
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B. Fill in the blanks. 

 

 Internet Service Providers       Newsgroup    Services          Hypertext    Process 

  

1. World wide web is one of the services provided by the internet. 

2. Companies that provide customers for internet access are called Internet service providers. 

3. Internet access is the process of connecting to the internet using computers. 

4. Web page is a hypertext document connected to the world wide web. 

5. A newsgroup is internet-based discussion on any thing in this world. 



  

C. Write ‘T’ for true and ‘F’ for false statements. 

  

1.  The word Internet comes from the combination of two words-Interconnection and network.                                                                           

( T ) 

2.  Internet and world wide web are same.                                                                 ( F ) 

3.  If you have a computer, you don’t need a modem to connect to the Internet.      ( F ) 

4.  Search engine is a software program that allows internet users search for content.                                 

( T ) 

5. BCC stands for Blind computer copy.                                                                    ( F ) 

  

D. Match the following. 

 1. WWW a. Hyper text transfer protocol 

2. CC b. Electronic mail 

3. Email c. World wide Web 

4. BCC d. Carbon copy 

5. HTTP e. Blind carbon copy 

 

Answer:-  1-c,  2-d,  3-b,  4-e,  5-a.  

 

 

E. Answer the following questions. 
  

1. Write a short note on Internet and mention its uses?  

Ans: The word internet comes from the combination of two words- Interconnection and Network. 
 It also refers to Global communication systems, Including hardware and infrastructure and 

the world wide web is one of the services provided by the internet. 

User of Internet are- 

1. Email 

2. Social networking sites 

3. Newsgroups 

4. E learning 

5. E Banking 

6. E commerce 

7. Entertainment 

 

2. What are the basic requirements for connecting to the internet? 

  

Ans: The basic requirements for connecting to the internet are as follows: 
          

1. A computer 

2. Internet service provider (ISP) 

3. Modem 

4. Internet access software 

5. Browser 

 

3. Write a short note on Internet terminology? 

  

Ans: The various Internet Terminologies are as follows: 

1. World wide web- It is a combination of all the resources on internet or it is a 



network of pages of images, texts and sounds on internet which can be viewed using 

a browser. 

2. Search Engine- It is a software program which allows internet users to search for 

contents via the World wide web for eg Google, Bing etc. 

3. Web Page- it is a hyper text document connected to the world wide web and contains 

text, graphics and hyperlinks to other webpages and files. 

4. URL address- URL is a short form of uniform resource locator. It is defined as the 

global address on documents on WWW eg www.google.com, www.yahoo.com 

5. HTTP:// - It stands for hypertext transfer protocol. It lets the browser to know what 

protocol is to be followed according the domain. 

6. Website- a website is a collection of related webpages. 

7. Address bar- it is a text box in a web browser displaying the address of the web 

page that is currently being viewed. 
  

4. What are the different internet services available to us? 
  

Ans: The different types of internet services available to us are as followed: 

1. Email 

2. Social networking sites 

3. Newsgroups 

4. E learning 

5. E Banking 

6. E commerce 
  

5. How can you add text, images and audio files to an Email? 

  

Ans: Follow the given steps to attach above files to your Email:- 

Step 1: Click on Compose. 

Step 2: Click on paper clip icon that says attach a file. 

Step 3: Select a file you want to attach. The file will be attached to your mail. 

  

F. Application based questions: 

  

   1 Your brother has just cleared his 12th board and is moving to a different city for his 

higher studies. What are the ways in which he can communicate to you using internet? 

Ans: He can communicate via Email, Audio call, Video call etc. 

 

2 Your father has to send power point presentation to his boss from home because he 

can’t go to the office today due to heavy rains.How can he send the PowerPoint 

presentation? 

Ans: He can send it as attachment through Email. 
 

http://www.google.com/
http://www.yahoo.com/
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A. Put a tick (√) the correct option. 

  

 1.  On an Excel spreadsheet the active cell is indicated by:  ? 

 (a) Dotted border                  

 (b) Italic Text 

 (c) Blinking border                                   

 (d) Dark wide border                   (√)                         

  

2. In a worksheet you can select : 

 (a) The entire worksheet                                     

 (b)  rows                  

 (c) columns 

 (d) All of the above                      (√)           

  

3. Which of these can be added to a cell ? 

 (a) Text 

 (b) Numbers                         

 (c) Formulas                      

 (d) All of the above                  (√)                  

  

4. The Namebox to the left of Formula bar shows : 

 (a) name of workbook currently working on           

 (b) name of workbook previously working on 

 (c) name of cell or range currently working on  (√) 

 (d) All of the above                           

  

5. An Excel workbook is collection of : 

 (a) Workbooks                      (√) 

 (b) Worksheets                     

 (c) Charts               

 (d) Worksheets and charts 

  

B. Fill in the blanks. 

 

 Save As              Existing       Spreadsheet    Active           Cell 

  

1. A cell with a dark border around it is called Active. 

2. The intersection point of a row and column is known as Cell. 

3. MS Excel is an example of Spreadsheet  program. 

4. Navigate to backstage view, and then click Open, to open an Existing workbook.  

5. To save a workbook in different version ,use Save As command. 

  



 

 

 

  

C. Match the following. 

 1. MS Excel a. Open Existing workbook 

2. The Ribbon b. Create a copy of a workbook 

3. Quick Access Toolbar c. A spreadsheet 

4. Backstage View d. Access common commands 

5. Save As e. Has multiple tabs 

 

Answer:-  1-c,  2-e,  3-d,  4-a,  5-b.  
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D. Answer the following questions. 
  

1. Write the steps to create a workbook ?  

Ans: Follow the given steps : 
 Step 1:- Select File Tab, backstage view appears. 

Step 2:-Select New, then click on blank workbook. 

 In this way  we can create a workbook. 

 

2. How can you open an existing workbook ? 

  

Ans: Follow the given steps:  

Step 1: Select the File tab backstage view appears. 

Step 2: Select Open, Open dialog box will appear. 
          

Step 3: Locate and select your workbook, then click Open. 

 

3. What are the different types of data that can be entered in Excel ? 

  

Ans: There are three types of data that can be entered in an Excel sheet- 

Text , Numbers and Formulas. 
  

4. Why do you use Save As command ?Write the steps for the same. 
  

Ans: If you want to make a copy or  save a workbook in different version while keeping the 

original one then we use Save As command. 

Follow the given steps: 

Step 1: Click Save As command from backstage view. 

Step 2: And choose where to save the file and give it a new file name .  
  

5. How do you select a cell ? 

  

Ans: Follow the given steps to select the cell :- 

Step 1: Click a cell to select it . 

Step 2: A border will appear around the selected cell and the column heading and row 

heading will be highlighted. 

  



E. Application based questions: 

  

   1 What are the different ways in which you can create a workbook ? Write the steps for 

the same. 

Ans: Answer is same as Answer 1. 

 

2 How can you add content to a cell ? 

Ans: Follow the given steps. 

Step 1: Click a cell to select it. 

Step 2: Type something into the selected cell and then press Enter on your keyboard. 

In this way content will appear in a cell. 
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A. Put a tick (√) the correct option. 

  

 1. Which of these can be added on a slide ? 

 (a) Animation                  

 (b) Narration 

 (c) Text                                   

 (d) All of these                   (√)                         

  

2. Which of these is not a slide background type ? 

 (a) Solid                                     

 (b) Gradient                  

 (c) Picture Fill 

 (d) Image Fill                      (√)           

  

3. SmartArt graphics contain : 

 (a) Text 

 (b) Graphic                         

 (c) Text and Graphics         (√)              

 (d)  None of these                                

  

4. Which of these is not an animation type ? 

 (a) Entrance           

 (b) Exit 

 (c) Motion paths 

 (d) ClipArt                          (√) 

  

5. During a slide show ,pressing the Esc key : 

 (a) Displays the last slide 

 (b) Displays slide 1                      

 (c) Ends the slide show        (√)               

 (d) Displays the previous slide 

  

B. Write ‘T’ for true and ‘F’ for false statements. 

  

1.  Placeholders holds text,pictures,charts ,etc.                                                          ( T ) 

2.  You cannot change the layout of the textbox.                                                       ( F ) 

3. By default ,all slides in a presentation have a transparent background.                ( T ) 

4.  Photo Album is used to create an album of pictures.                                            ( T ) 

5. SmartArt lets you to communicate information with graphics only.                     ( F ) 

  

 

 

 

Rakesh-HM
Note



  

D. Match the following. 

 1. Images Group a. Subtle 

2. Illustration group b. Motion Path 

3. Animation c. Photo Album 

4. Transition d. Slide view 

5. Reading View e. Shapes 

 

Answer:-  1-c,  2- e,  3-b,  4-a,  5- d 

  

E. Answer the following questions. 
  

1. Write a short note on PowerPoint  Slides ?  

Ans: PowerPoint presentations are made up of a number of slides. These slides contain the 

information you want to present to your audience .This can be text,pictures, charts etc. 
   

2. Write steps to change the background of a slide ? 

  

Ans: Follow the given steps to change the background of slide :- 
 1. Select Design Tab and click on Format background command. 
 2.Then format background pane appear on right .Select the desired fill options. 
 3.The background style of the selected slide will update. 
  

3. How can you change the layout of a Smart Graphic ? 

Ans: Follow the given steps to change the layout of a SmartArt Graphic:- 
 1. From Design Tab, Click the drop down arrow in Layouts group. 
 2.Choose the desired layout or click More Layouts to see even more options. 
 3.The selected layout will appear. 
  

4. What are the difference types of audios you can add to a slide ?  
  

Ans: The different types of Audio you can add to a slide are  

1)Audio from PC and 2) Record Audio. 
  
  

5. Write a short note on the different types of layouts used while printing ? 

  

Ans: Different types of layouts used while printing are :- 

 1)Full page Slides 

2)Notes Pages 

3)Outline 

4)Handouts 

 1) Full page Slides :- This prints a full page for each slide in your presentation. This layout 

is useful if you want to review or edit a printed copy of your presentation. 

2)Notes Pages :- This prints each slide with any speaker notes for the slide.They are helped 

during presentation. 

3)Outline:- This prints an outline of the slideshow.You can use this to review the 

organisation of your slideshow . 

4)Handouts :- This prints thumbnail versions of each slide with optional space for notes. 
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A. Put a tick (√) the correct option. 

  

 1. ____________ is used to enlist items in MS Word. 

 (a) Bullets and numbers                  (√)    

 (b) Lists 

 (c) Format                                   

 (d) None of these                                      

  

2. _____________ is the inbuilt dictionary in MS Words. 

 (a) Thesaurus                                     (√)           

 (b) Dictionary                  

 (c) Spell Check 

 (d) None of these      

  

3. The misspelt words are underlined with a ____________ line in MS Word. 

 (a) Green Wavy lines 

 (b) Red Wavy lines                             (√) 

 (c) Maroon wavy lines                    

 (d)  None of these                                

  

4. ______________ are underlined with green wavy lines. 

 (a) Grammatically incorrect words     (√)           

 (b) Misspelt words             

 (c) Words not in in-built dictionary 

 (d) None of these 

  

5. __________ window appears when we press SHIFT +F7 on the keyboard. 

 (a) Research Window                         (√) 

 (b) Graph Window                      

 (c) Picture Window                         

 (d) None of these 

  

B. Fill in the blanks. 

  

 Thesaurus Numbers & Bullets Misspelt words Grammatically incorrect words Borders 

  

1. Thesaurus  is the inbuilt dictionary in MS Words. 

2. Numbers & Bullets helps in enlisting the text. 

3. Borders  helps in enhancing the look of the data. 

4. Grammatically incorrect words  are underlined with green wavy lines. 

5. Misspelt words    are underlined with red wavy lines. 

  



C. Write ‘T’ for true and ‘F’ for false statements. 

1.  Grammatically incorrect words  are underlined with green wavy lines.              ( T ) 

2.  Misspelt words are underlined with red wavy lines.                                             ( T ) 

3. Thesaurus  is the inbuilt dictionary in MS Words.                                                 ( T ) 

4.  SHIFT +F7  opens the bullet dialogue box.                                                          ( F ) 

5.  Spelling and Grammar option is present under the format menu.                        ( F ) 
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D. Match the following. 

 1. Red wavy lines a. Grammatically incorrect 

2. Bullets and numbers dialogue box b. Dictionary   

3. Green wavy lines c. Formatting toolbar 

4. Thesaurus d. Misspelt words 

5. Borders e. Enlisting text 

 

Answer:-  1-d,  2- e,  3-a,  4-b,  5- c 

  

E. Answer the following questions. 
  

1. What is spelling and grammar check ?  

Ans: In order to make our writing effective and easier MS Word provide a feature of spelling and  
 grammar check .It identifies misspelt words by adding a red wavy line under the word and  
 Grammatical mistakes it marked by green wavy lines. 
  

2. What is the use of Thesaurus ? 

  

Ans: MS Word has its won in-built dictionary called Thesaurus and one can add synonyms and  
 Antonyms for words using this dictionary. 
  

3. How can you customise bullets ? 

Ans: To be explained practically. 
  

4. How can you add borders in your document ? 
  

Ans: Click on Page Layout -> Page Borders -> Borders & Shading Dialog Box Appears. 
 Choose the border style , colour and width from the Dialog box. 
  

5. How can you add numbers to your list ? 

  

Ans: Follow the steps :- 

 Step 1:- Select the list . 

Step 2:- From Home tab, click on Numbering command. 

Step 3:-A menu of numbering styles appear. 

Step 4:-Move the mouse on desired style the list will be numbered accordingly. 

F. Application based questions. 

  

 Write an essay from your English book. After typing ,check its grammar and spelling 

using MS Word.Also find the synonyms of different words using the Theasurus. 

 To be done Practically. 
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A. Put a tick (√) the correct option. 

  

 1. Which of the following is not true regarding WordArt ? 

 (a) Right-click the object               

 (b) Click the object 

 (c) Double click the object                  

 (d) Triple click the object             (√) 

  

2. Which of the following positions is not available for fonts on MS Word ? 

 (a) Normal                                

 (b) Raised          

 (c) Lowered 

 (d) Centered                                   (√)           

  

3. Bold,Italic,Regular are known as ? 

 (e) Font Styles 

 (a) Font Effects                     

 (b) WordArt                    

 (c) Text Effects                               (√) 

  

4. Changing the appearance of a document is called : 

 (a) Proofing            

 (b) Editing                                       (√)           

 (c) Formatting 

 (d) All of the above 

  

B. Fill in the blanks. 

  

 Text Group        Text effects          WordArt          Web            TextBox 

  

1. WordArt gallery is available in the Insert Tab. 

2. The WordArt icon is located in the Text Group. 

3. To create a curved effect ,on the Drawing Tools Format tab, click Text Effects. 

4. Select the Insert tab and then click the Textbox command to insert a text box.. 

5. Select Insert >Online Pictures for a picture thats on the Web. 

  

C. Write ‘T’ for true and ‘F’ for false statements. 

1. Word 2016 is similar to Word 2013 but different from Word 2010.                           ( F ) 

2. Existing text can be converted to Word Art in MS Word.                                           ( T ) 

3. You can change the fill and outline colour of  WordArt text.                                      ( T ) 

4. In Word 2016 you can only add pictures from your PC.                                              ( F ) 

5. You can wrap text along a picture.                                                                               ( T ) 



D. Answer the following questions. 
  

1. Write the steps to insert WordArt ?  

  

Ans: Follow the given steps to insert WordArt in your text :- 
 Step 1:- Click Insert-> WordArt , and select the WordArt style you want. 
 Step 2:- The placeholder text “Your text here “ appears with the text highlighted. 
               Enter your own text to replace the placeholder text. 
  

2. How can you add effects to your WordArt ? 

  

Ans: To add effects like shadows, rotation ,curves, fill and outline colours ,we can use the options 
 in the WordArt Styles group ,including Text Fill ,Text Outline and Text Effects.  
  

3. Write the steps to insert a TextBox ? 

  

Ans: Follow the given steps:- 
 Step 1 :- Select the Insert tab and then click the text Box command in the Text Group. 
 Step 2 :- A dropdown menu will appear .Select Draw Text Box. 
 Step 3:- Click and drag anywhere on the document to create the text box. 
  

4. How can you modify text boxes ? 
  

Ans: Cancelled 
  

5. What is wrap text and how do you do it? 

   

Ans: Cancelled 

  

E. Application based questions. 

  

 These questions should be done Practically. 
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Let us Enter 

Rearrange the words. 

R C O T M P U E  C O M P U T E R 

   

U C U M A A B S E U T  V A C C U M T U B E S 
 

A B A C U S  A B A C U S 
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A. Put a tick (√) the correct option. 

  

 1. Who invented the Pascaline ? 

 (a) Blaise Pascal                 (√) 

 (b) John Napier 

 (c) Gottfried Leibniz 

 (d) Lady Ada Lovelace 

  

2. Who is the first woman programmer? 

 (a) Blaise Pascal                  

 (b) John Napier                  

 (c) Gottfried Leibniz 

 (d) Lady Ada Lovelace     (√) 

  

3. Which technology was used in second generation computers? 

 (a) Vacuum Tubes 

 (b) Integrated Circuits                      

 (c) Transistors                   (√) 

 (d) All of the above 

  

4. UNIVAC belongs to which generation of computers? 

 (a) First                             (√) 

 (b) Second                         

 (c) Third 

 (d) Fourth 

  

5. Which was the first calculating device ? 

 (a) Calculator                          

 (b) Abacus                       (√) 



 (c) Computer 

 (d) None of these 
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B. Write ‘T’ for true and ‘F’ for false statements. 

  

1. Abacus is an Indian Invention.                                                                                    ( F ) 

2. The frame of the abacus has a series of vertical rods.                                                 ( T ) 

3. Gottfried Wilhelm Von Leibniz invented the Analytical Engine.                               ( F ) 

4. There are five generations of computers.                                                                    ( T ) 

5. The fifth generations of computers is based on Artificial Intelligence.                      ( T ) 

  

C. Match the following. 

 1. Lady Ada Lovelace a. Third Generation 

2. First Generations of Computers b. Fourth Generation 

3. Transistors c. First woman computer programmer 

4. IBM-360 Series d. Second Generation 

5. Microprocessor Chips e. From 1940-1956 

 

Answer:-  1-c,  2- e,  3-d,  4-a,  5- b 

  

D. Answer the following questions. 
  

1. What is Abacus and explain its structure ?  

  

Ans: Abacus is first calculating device invented by China 5000 years ago in 3000 BC. 
 Structure:- The frame of Abacus has a series of vertical rods on which a number of wooden 
 beads are allowed to slide freely. It has upper and lower deck. Each bead in upper deck has a 
 value of 5 and in lower deck each bead has value of 1. 
 

 
  

2. Who is known as ‘Father of Computers ‘ and why ? 

  

Ans: Charles Babbage is known as the ‘Father of Computers ‘ because of  his research into  
 machines that could calculate. He invented Difference Engine and Analytical Engine. 
  
  



3. Write a short note on generations of computers. 

  

Ans: By generation  of computers  we simply mean the different stages of development of a basic  
 computer. Computers can be classified into five generations and it is mainly classified on the 
 device it used. 
 1st Generation- Vacuum Tubes 
 2nd Generation- Transistors 
 3rd Generation- Integrated Circuits 
 4th Generation -Microprocessors 
 5th Generation- Artificial Intelligence 
  
  

4. Write a short note on 1st generation of Computers? 
  

Ans: (a) Time period of 1st generation of computers is from 1940-1956.  
 (b) It used Vacuum Tubes for circuitry and magnetic drums for storing data.  
 (c) They were very large in size and were room sized computers. 
 (d) Examples are ENIAC, UNIVAC, EDVAC and EDSAC. 
  

5. Write a short note on 5th generation of Computers? 

   

Ans: (a) Time period of 5th   generation of computers is from 1989-Present.  

 (b) It used Artificial Intelligence and it is still in a developing stage. 

 (c) Computer of this generation can understand spoken words and imitate human reasoning. 

 (d) Examples are Robots, Nano Computers and Quantum computers. 

  

D. Application based questions. 

  

1. Abhishek has decided to help his mother in calculating the daily expenses of their 

family. What machine should he use to make his and his mother’s work simple, easy 

and without any mistake? 

Ans: Calculator 

  

2. Rani’s father uses a AMC Notebook at office. Which generation of computer does he 

use  

Ans: Fourth Generation. 
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A. Put a tick (√) the correct option. 

  

 1. Which of the following is not an impact printer? 

 (a) Dot Matrix                  

 (b) Daisy Wheel 

 (c) Inkjet                                  (√) 

 (d) Line                                      

  

2. Which of these is not an external memory? 

 (a) ROM                                   (√)           

 (b) CD                  

 (c) DVD 

 (d) Pen Drive      

  

3. Which of the following is not a type of CD? 

 (a) CD-R 

 (b) CD-ROM                      

 (c) CD-RW                    

 (d) CD-EX                                (√) 

  

4. Speed for accessing data is faster in: 

 (a) Secondary Memory            

 (b) Primary Memory                (√)           

 (c) Pen Drive 

 (d) Hard Disk 

  

5. Which of these is an impact printer? 

 (a) Inkjet Printer                          

 (b) Laser Printer                               

 (c) Line Printer                         (√) 

 (d) None 

  

B. Fill in the blanks. 

  

 Primary  Secondary   Keyboard Input    Output    Primary   Secondary 

1. Input and Output devices are also known as peripherals. 

2. Computer memory is divided into two parts-Primary and Secondary. 

3. Primary is directly accessible by CPU. 

4. USB, CD, DVD, Pen drive all are types of Secondary storage devices. 

5. Keyboard is a text based input device that allows the user to input alphabets, numbers and 

 other characters. 

  



C. Write ‘T’ for true and ‘F’ for false statements. 

1. A computer uses input devices to take inputs from a user.                                         ( T ) 

2. Output devices are not peripherals.                                                                             ( F ) 

3. Mouse is a type of input device.                                                                                  ( T ) 

4. Printers are of two types-impact and non-impact printers.                                          ( T ) 

5. Primary memory is made up of magnetic and optical material.                                  ( F ) 
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D. Match the following. 

 1. IPO Cycle a. Primary Memory 

2. Keyboards b. Secondary Memory 

3. Printers c. Input Process Output Cycle 

4. RAM d. Output Device 

5. Pen Drive e. Input device 

 

Answer:-  1-c,  2- e,  3-d,  4-a,  5- b 

  

E. Answer the following questions. 
  

1. What is a computer memory and name its parts?  

  

Ans: Computer memory is a physical device capable of storing information temporarily or 

permanently. 
  It is divided into two parts - (1)Primary Memory    (2) Secondary Memory 
  

2. Explain Primary memory in detail. 

  

Ans: Primary memory is the main memory of a computer. The instructions that have to be 
 currently executed are copied to the primary memory because CPU can directly access the 
 data from primary memory. 
 Types of primary memory -  (1) RAM  -Random Access Memory 
                              (2) ROM - Read Only Memory 
  

3. What are the different types of printers and what kind of device a printer is? 

  

Ans: Printers are classified as (1) Impact and (2) Non Impact Printers. 
 Impact printers are - (1) Dot Matrix, (2) Daisy Wheel and (3) Line Printer. 
 Non Impact Printers are -  (1) Inkjet and  (2) Laser Printer 
  Printer is an Output Device. 
  

4. What is a CD? How many types of CDs are there? Explain in detail. 
  

Ans: Full form of CD is Compact Disc. It is most popular among all storage devices. It is round in 

shape and can store up to 800 MB of data. 
 CD is also of three types:  
 (1) CD ROM : It is read only memory and you cannot add or remove anything from it. 
 (2) CD- R :You can record data in it but cannot edit it. 
 (3) CD-RW : You can write and erase both on this type. Therefore, they can be used again   



                       and again. 
  

5. Write any four differences between primary and secondary memory? 

   

Ans: Primary Memory Secondary Memory 

1. It is main memory of computer. 1. It is also called as auxiliary memory or 

backup memory. 

2. It is directly accessible by CPU. 2. It is not directly accessible to CPU. 

3. Speed of accessing data is faster. 3. Speed is slower. 

4. Examples are RAM and ROM. 4. Examples are Hard disk, CD, DVD, 

Pen drive/flash drive etc. 
 

  

F. Application based questions. 

  

1. Ayush was trying to draw an image of a lion on the computer screen itself. 

 a. What device was he using? 

 b. What kind of a device is it –input or output? 

  

Ans: (a) Mouse 

 (b) Input 

  

2. Ayesha wanted to download a picture of her favourite actor and get a hard copy of the 

same. 

 a. What device should she use to get a hard copy from the computer? 

 b. What kind of device is it – input or output? 

  

Ans: (a) Printer 

 (b) Output 
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